RIP functions by periodically flooding the entire routing table out to the network, it generates a lot of traffic. The split horizon and poison reverse techniques can help to reduce the large amount of network traffic .Never tell someone what they told you .
R1#sh run | s rip
router rip
version 2
passive-interface FastEthernet0/0
network 1.0.0.0
network 10.0.0.0
neighbor 10.1.12.3
neighbor 10.1.12.2
no auto-summary
R2#sh run | s rip
router rip
version 2
passive-interface FastEthernet0/0
network 2.0.0.0
network 10.0.0.0
neighbor 10.1.12.1
no auto-summary
Split Horizon Rule is enable in RIP by default
R3#sh run | s rip
router rip
version 2
passive-interface FastEthernet0/0
network 3.0.0.0
network 10.0.0.0
neighbor 10.1.12.1
no auto-summary
R3(config)#int f 0/0
R3(config-if)#shut
R3(config-if)#no shut
R3#sh ip int f 0/0
FastEthernet0/0 is up, line protocol is up
Internet address is 10.1.12.3/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.9
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
R1#sh ip route rip
2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/1] via 10.1.12.2, 00:00:13, FastEthernet0/0
3.0.0.0/24 is subnetted, 1 subnets
R 3.3.3.0 [120/1] via 10.1.12.3, 00:00:14, FastEthernet0/0
R3#sh ip route rip
1.0.0.0/24 is subnetted, 1 subnets
R 1.1.1.0 [120/1] via 10.1.12.1, 00:00:05, FastEthernet0/0
After disable Split Horizon in RIP
R3(config)#int f 0/0
R3(config-if)#no ip split-horizon
R3(config-if)#do sh ip int f 0/0
FastEthernet0/0 is up, line protocol is up
Internet address is 10.1.12.3/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.9
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is disabled
R3(config-if)#do sh ip route rip
1.0.0.0/24 is subnetted, 1 subnets
R 1.1.1.0 [120/1] via 10.1.12.1, 00:00:18, FastEthernet0/0
2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/2] via 10.1.12.2, 00:00:18, FastEthernet0/0
router rip
version 2
passive-interface FastEthernet0/0
network 1.0.0.0
network 10.0.0.0
neighbor 10.1.12.3
neighbor 10.1.12.2
no auto-summary
R2#sh run | s rip
router rip
version 2
passive-interface FastEthernet0/0
network 2.0.0.0
network 10.0.0.0
neighbor 10.1.12.1
no auto-summary
Split Horizon Rule is enable in RIP by default
R3#sh run | s rip
router rip
version 2
passive-interface FastEthernet0/0
network 3.0.0.0
network 10.0.0.0
neighbor 10.1.12.1
no auto-summary
R3(config)#int f 0/0
R3(config-if)#shut
R3(config-if)#no shut
R3#sh ip int f 0/0
FastEthernet0/0 is up, line protocol is up
Internet address is 10.1.12.3/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.9
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
R1#sh ip route rip
2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/1] via 10.1.12.2, 00:00:13, FastEthernet0/0
3.0.0.0/24 is subnetted, 1 subnets
R 3.3.3.0 [120/1] via 10.1.12.3, 00:00:14, FastEthernet0/0
1.0.0.0/24 is subnetted, 1 subnets
R 1.1.1.0 [120/1] via 10.1.12.1, 00:00:05, FastEthernet0/0
R3(config)#int f 0/0
R3(config-if)#no ip split-horizon
R3(config-if)#do sh ip int f 0/0
FastEthernet0/0 is up, line protocol is up
Internet address is 10.1.12.3/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.9
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is disabled
R3(config-if)#do sh ip route rip
1.0.0.0/24 is subnetted, 1 subnets
R 1.1.1.0 [120/1] via 10.1.12.1, 00:00:18, FastEthernet0/0
2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/2] via 10.1.12.2, 00:00:18, FastEthernet0/0
No comments:
Post a Comment