Thursday, February 19, 2015

RIP v2 unicast neighbor



R1(config)#int loopback 0
R1(config-if)#ip add 1.1.1.1 255.255.255.0
R1(config-if)#exit
R1(config)#int f 0/0
R1(config-if)#ip add 10.1.12.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#net 1.1.1.0
R1(config-router)#net 10.1.12.0
R1(config-router)#nei 10.1.12.2
R1(config-router)#nei 10.1.12.3
R1(config-router)#no auto-summary


R2#sh run | s rip
router rip
version 2
network 2.0.0.0
network 10.0.0.0
neighbor 10.1.12.1
no auto-summary

R3#sh run | s rip
router rip
version 2
network 3.0.0.0
network 10.0.0.0
neighbor 10.1.12.1

no auto-summary

NOTE:
An interface configured as passive will still receive RIP updates on that interface and the interface subnet will still be advertised out even if that interface will not send updates to its directly connected neighbour.

Running passive interface on all router interface

R1#sh run | s rip
router rip
version 2
passive-interface FastEthernet0/0
network 1.0.0.0
network 10.0.0.0
neighbor 10.1.12.3
neighbor 10.1.12.2
no auto-summary




No comments:

Post a Comment